OMVL dream, V6 mondeo, no workie!

The main forum
peanucklejive
Posts: 1
Joined: Sun Jul 21, 2013 9:47 pm
LPG System: OMVL Dream XXI
Car: Mondeo ST220

OMVL dream, V6 mondeo, no workie!

Postby peanucklejive » Sat Aug 31, 2013 7:54 pm

Hey all, new member here, I feel bad my first post is asking for help but I'm having problems!

So I got a Mondeo ST220 in may, OMVL dream XXI fitted since 2007. I had problems for a while with it running lean and bringing the engine management light on for a while. Gave the car a service and now it misfires (I think) like crazy!

Changing spark plugs is a big job, the rear bank is covered by the inlet plenum so I'm hoping its not the plugs but may well be!

So, I changed plugs to the right ones for the car in June. Gapped at 1.3mm. I've since read you have to regap plugs for LPG use. So I took them out and regapped to 1mm yesterday, still no good.

Runs completely perfect on petrol, the ECU registers a misfire on LPG, usually cylinder 5. I switched HT leads about and the misfire stayed on 5, switched injector solenoids about and it still remained on 5. Sometimes it misfires so much the system switches back to petrol and beeps at me, when I check the laptop it says map sensor.

The LPG system has had a new map sensor, new reducer temp sensor, new filters and reducer diaphragms.

What to check next? I'm getting really tired of farting about with it, could it be a mapping issue? I played with the map a little but no matter what I did it didn't really seem to get better

Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 5 guests