Second hand LPG car with problems...

The main forum
Post Reply
darkcyde
Posts: 4
Joined: Sun Mar 23, 2014 10:23 am
LPG System: Landi Renzo
Car: Toyota Surf SSRX

Second hand LPG car with problems...

Post by darkcyde » Tue Mar 25, 2014 4:51 pm

Hi all - I've just purchased a Toyota Surf 2.7L with an LPG conversion. Unfortunately, I couldn't see it working when I purchased it as the tank was completely empty, and the bloke fobbed me off saying there were'nt any stations near him, which I now know is a complete lie...oh well, live and learn.

Anyway, it's got a Landi Renzo Omegas system fitted.....when I first filled the tank, I tried switching over and it just beeped at me....1 second long beep, 1 second long gap.

Being an ex gas engineer, I figured if the tank had been completely expelled, then it might need purging, so I found the fuel line and pulled some gas through. When doing this, I noticed some loose hoses (air pressure type coming from various bits on the manifold) which I found their homes and plugged them back in.

So now, its ticks over fine on gas quite happily until you try to move off, then it starts it's beeping again! I got hold of a diagnostic cable, and reset the ECU to get fresh codes, and the error coming up is Low Pressure.

Has anyone got any ideas? According to the software, my pressure sits at about 0.62bar, which seems a little low to me....anyway of adjusting this on the regulator?

darkcyde
Posts: 4
Joined: Sun Mar 23, 2014 10:23 am
LPG System: Landi Renzo
Car: Toyota Surf SSRX

Re: Second hand LPG car with problems...

Post by darkcyde » Wed Apr 02, 2014 3:34 pm

Hmmm.....I guess these forums are a little dead then, huh?

Post Reply