Prins VSI on mercedes ml 500 Faulty

The main forum
Post Reply
davelaut
Posts: 5
Joined: Sun Sep 21, 2014 8:40 am
LPG System: Prins
Car: Mercedes ML500

Prins VSI on mercedes ml 500 Faulty

Post by davelaut » Sat Apr 11, 2015 4:43 pm

Hi
I have an Ml 500 and have been running the LPG system for the last 4 years with no problems. However now it won't run on LPG when i start up in the morning the normal orange light comes on, when the car is up to temperature it tries to switch over and the 4 green lights momentarily come on the car then splutters and then continues to run on petrol without any problems. I have changed both of the filters and i know the tank is full as i topped it up just to be sure i didn't have a faulty fuel level gauge.

Does anyone have any suggestions of potential issues that i can check?

Thanks and i look forward to hearing your comments.
Dave

davelaut
Posts: 5
Joined: Sun Sep 21, 2014 8:40 am
LPG System: Prins
Car: Mercedes ML500

Re: Prins VSI on mercedes ml 500 Faulty

Post by davelaut » Wed Apr 22, 2015 6:58 pm

I purchased the diagnostic software and cable, and i am finally getting somewhere, in so far as the fault code tells me that "my tank is empty" the only problem with this is that my tank is full so time to look a little further.

mak-uk
Posts: 288
Joined: Mon Sep 03, 2007 8:48 pm
LPG System: Prins VSI
Car: BMW 540iA Sport
Location: All over the UK

Re: Prins VSI on mercedes ml 500 Faulty

Post by mak-uk » Sat May 02, 2015 10:52 pm

Faulty tank float?
Mak
Site Owner
2001 BMW 540i Auto Sport Saloon
~300 BHP; ~320 ft/lbs, Prins VSI system

davelaut
Posts: 5
Joined: Sun Sep 21, 2014 8:40 am
LPG System: Prins
Car: Mercedes ML500

Re: Prins VSI on mercedes ml 500 Faulty

Post by davelaut » Thu May 07, 2015 8:20 pm

Hi
Turned out to be a faulty diaphragm, got a repair kit from Tinleytech. when i spoke with their technical department they were really helpful.

davelaut
Posts: 5
Joined: Sun Sep 21, 2014 8:40 am
LPG System: Prins
Car: Mercedes ML500

Re: Prins VSI on mercedes ml 500 Faulty

Post by davelaut » Mon May 18, 2015 7:38 pm

Hi
Changed the diaphragm and all was looking good, i now have an additional fault the vaporizer pressure relief valve is operating and then switches back to petrol. any suggestions?

On another point changing the diaphragm was really easy.

davelaut
Posts: 5
Joined: Sun Sep 21, 2014 8:40 am
LPG System: Prins
Car: Mercedes ML500

Re: Prins VSI on mercedes ml 500 Faulty

Post by davelaut » Thu Jun 11, 2015 8:20 pm

Well finally i had to replace the Vaporiser which i was able to get from Tinley Tech who have been really helpful. It started working straight away however i have now found that it still wants to switch back to Petrol when i get to 1/2 a tank so i may well have another problem with the float in the tank just got to try and figure it out. As always all suggestions are welcome, Thanks
Dave

Post Reply