Lumpy running on petrol after switching from gas

The main forum
Post Reply
nickw
Posts: 2
Joined: Sun Nov 21, 2010 5:12 pm
LPG System: Prins
Car: Saab 95

Lumpy running on petrol after switching from gas

Post by nickw » Sun Nov 21, 2010 9:43 pm

If I drive the car (Saab 9-5 2.3 Lpt) on gas and I switch to petrol during the journey it goes lumpy and the engine check light comes on.
Also having driven on gas to work and the car has cooled down enough say by lunch time, it starts on petrol and is lumpy until it switches over to gas. But if the car is left overnight and I start it in the morning it's fine. Injectors were cleaned at the last service, plugs, fuel pump fine. Any thoughts would be appreciated. Cheers, Nick.

mak-uk
Posts: 288
Joined: Mon Sep 03, 2007 8:48 pm
LPG System: Prins VSI
Car: BMW 540iA Sport
Location: All over the UK

Re: Lumpy running on petrol after switching from gas

Post by mak-uk » Mon Nov 22, 2010 1:02 pm

To me, that sounds like a tuning and/or fuel trim problem. Best get it checked by your installer.
Mak
Site Owner
2001 BMW 540i Auto Sport Saloon
~300 BHP; ~320 ft/lbs, Prins VSI system

nickw
Posts: 2
Joined: Sun Nov 21, 2010 5:12 pm
LPG System: Prins
Car: Saab 95

Re: Lumpy running on petrol after switching from gas

Post by nickw » Tue Nov 23, 2010 8:45 pm

Thanks Mak, will do.
All the best,
Nick.

daveylitz
Posts: 4
Joined: Tue Aug 02, 2011 7:47 pm
LPG System: koltec egi
Car: vauxhall vectra 2.0l

Re: Lumpy running on petrol after switching from gas

Post by daveylitz » Tue Aug 16, 2011 7:52 pm

what codes are logged?

Post Reply